Gimp 2.8.0 i Fedora 16 (instaliranje)

Najzad se pojavila nova stabilna verzija Gimp-a. U pitanju je verzija 2.8.0.

Binarne verzije za Windows, Mac i neke Linux distribucije se mogu preuzeti.
Na zalost u Fedori 16 se jos nije pojavila verzija 2.8.0, a pitanje je i da li ce se uopste pojavljivati. sudeci po informacijama sa raznih foruma, verzija 2.8.0 ce biti dostupna u Fedori 17.

Ali uz malo truda i malo vise vremena, moguce je kompajlirati Gimp 2.8.0. U ovom clanku cu Vam opisati kako to da uradite.

Kao prvo, da Vas uputim na ovu adresu: http://gimper.net/viewtopic.php?f=30&p=112944
Jer sam na gore pomenutoj adresi nasao detaljno uputstvo kako to uraditi u Fedori 16. Medjutim, na mom kompjuteru se pojavila greska Could not find PyGTK 2.10.4 or newer, a i uputstvo na tom forumu je na engleskom, ja cu ga ovde prevesti sa jos par dodatnih koraka koje sam uradio. Takodje se zahvaljujem korisniku foruma sa nadimkom sagteck koji je napisao uputstvo za kompajliranje, koje mi je ustedelo puno vremena prilikom kompajliranja.

1. Pokrenite terminal i u terminalu ukucajte: su - pritisnite enter i zatim ukucajte root sifru, zatim opet enter.
2. Deinstalirajte prethodnu verziju Gimp-a: yum erase gimp
3. Azurirajte sistem: yum update
4. Restarujte kompjuter, opet pokrenite terminal i u terminalu ukucajte: su - pritisnite enter i zatim ukucajte root sifru, zatim opet enter.

U terminalu ukucajte sledece komande da bi se instalirali potrebni paketi:

5. yum install pygtk2-devel (ovo sam morao instalirati jer se kod mene pojavila greska: Could not find PyGTK 2.10.4 or newer)
6. yum groupinstall "Development Libraries"
7. yum groupinstall "Development Tools"
8. yum groupinstall "Legacy Software Development"
9. yum install wget git exiv2 exiv2-devel libspiro libspiro-devel libv4l libv4l-devel lua lua-devel enscript asciidoc v4l-utils libopenraw libopenraw-devel jasper jasper-devel graphviz graphviz-devel SDL SDL-devel librsvg2 librsvg2-devel OpenEXR OpenEXR-devel libtiff libtiff-devel libjpeg libjpeg-devel libpng libpng-devel aalib aalib-devel ghostscript ghostscript-devel webkitgtk webkitgtk-devel lcms lcms-devel libmng libmng-devel poppler poppler-devel librsvg2 librsvg2-devel libwmf libwmf-devel libXpm libXpm-devel libexif libexif-devel libgudev1 libgudev1-devel xorg-x11-server-Xvfb -y

Zatim promenite sledece putanje tako sto ce te u terminal ukucati sledece komande:
10. export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
11. export LD_LIBRARY_PATH=/usr/local/lib
12. cd /usr/local/src/

Da bi ste preuzeli i raspakovali potrebne fajlove sa interneta ukucajte:
13. git clone git://git.gnome.org/babl
14. git clone git://git.gnome.org/gegl
15. wget http://ftp.gnome.org/pub/gnome/sources/gtk+/2.24/gtk+-2.24.10.tar.xz
16. tar -xf gtk+-2.24.10.tar.xz
17. wget ftp://ftp.gimp.org/pub/gimp/v2.8/gimp-2.8.0.tar.bz2
18. tar -xf gimp-2.8.0.tar.bz2

Kompajlirajte pakete po sledecem redosledu:
Babl:
19. cd babl
20. ./autogen.sh
21. ./configure
22. make && make install
23. cd ..

Gegl:
24. cd gegl
25. ./autogen.sh
26. ./configure
27. make && make install
28. cd ..

gtk+-2.24.10:
29. cd gtk+-2.24.10
30. ./configure
31. make && make install
32. cd ..

i najzad gimp-2.8.0
33. cd gimp-2.8.0
34. ./configure
35. make && make install
36. cd ..

Gimp pokrecete komandom gimp iz terminala. Takodje mozete napraviti simbolicki link (precicu) na desktopu.

About darthewok

Kompjuterski entuzijasta sa preko 30 godina iskustva.

Posted on 2012/05/07, in Fedora 16, Gimp tutorijali and tagged , , . Bookmark the permalink. Leave a comment.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: